JOOM::GALLERY::FORUM

Archive => Modules => Topic started by: spotdesign on 01-06-2012 15:04:27



Title: Problem with JoomCategories module and Internet Explorer 8
Post by: spotdesign on 01-06-2012 15:04:27
Hi,

I have installed JoomGallery with JoomCategories module; all is ok except for a problem in the slideshow view of the JoomCategories module with Internet Explorer 8 (no problem with Firefox and Safari). I set thumbnail link to "Slideshow" with "Show infopane", "Show carousel" and "Show arrows" options enabled; the images are display correctly, but when I move the mouse over the image, the infopane didn't appears and a visualization error is generated. If I click to see error's details I get this:

Web page error details

User agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Timestamp: Thu, 31 May 2012 22:43:52 UTC


Message: Unknown runtime error
Line: 38
Caharacter: 1402
Code: 0
URI: http://www.pezzidilegno.it/media/system/js/mootools.js

What can I do?

Thanks!


Title: Re: Problem with JoomCategories module and Internet Explorer 8
Post by: Erftralle on 01-06-2012 17:51:19
Hi,

sorry, but I can't reproduce the error in my local test environment.
 
Please tell us more about your versions (Joomla!, JoomGallery, JoomCategories), the module settings of JoomCategories
AND please provide a link showing the problem.

Regards
Erftralle


Title: Re: Problem with JoomCategories module and Internet Explorer 8
Post by: spotdesign on 01-06-2012 18:33:06
Hi,

thanks for reply.

Joomla version is 1.5.26
JoomGallery version is 1.5.7.5
JoomCategoris version is 1.5.7.1

I have generate a screenshot in which you can see the settings of JoomCategories module, but I get an error when I try to upload it.
You can see the problem with Internet Explorer 8 at this link:
http://www.pezzidilegno.it/opere/animali.html

Regards.
Daniele


Title: Re: Problem with JoomCategories module and Internet Explorer 8
Post by: Erftralle on 01-06-2012 23:32:32
Hi,

thanks for the link.


As a first possibility you could try out the following two changes in the ../components/com_joomgallery/assets/js/smoothgallery/scripts/jd.gallery.js:

In line 658 change
Code
    var slideInfoZoneDescription = new Element('p').injectInside(this.slideInfoZone.element);
to
Code
    var slideInfoZoneDescription = new Element('div').injectInside(this.slideInfoZone.element);

and line 672 from

Code
    element.getElement('p').setHTML(this.galleryData[this.currentIter].description);
to
Code
    element.getElement('div').setHTML(this.galleryData[this.currentIter].description);

Another possibility would be to avoid the surrounding <p></p> tags in your image description (e.g 'thrthtrh ht htr hrt' instead of <p>thrthtrh ht htr hrt</p>).

Regards
Erftralle


Title: Re: Problem with JoomCategories module and Internet Explorer 8
Post by: spotdesign on 02-06-2012 17:16:12
Hi,

thanks, I used the first solution and now it works very well also with Internet Explorer 8.

I have 2 questions about infopane:
1) Infopane appears everytime the image is loaded or only when I move the mouse over the image?
2) Is it possible to change the font used in infopane?

Thanks.
Regards.
Daniele