JOOM::GALLERY::FORUM

JoomGallery 3.x JUX => Frontend => Topic started by: loppis on 15-12-2017 11:56:25



Title: No photos in frontend (404 error) after enabling SEF
Post by: loppis on 15-12-2017 11:56:25
Hi,

when I enable SEF, no photos at all are shown in the frontend anymore.

My website is running on nginx, and I did read this page : http://www.en.joomgallery.net/documentation/common-information/sef-urls-for-images.html , and I must say I'm completely new to nginx and I don't know how the web.config file works, and I couldn't find the suggested line :

Code:
<add input="{URL}" pattern="/component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$" />

so I don't dare to mess with it :).

However, there is an obvious problem with the paths, I do get a 404 error in the console :

Code:
GET http://www.crashdiet.org/photos/image-2189-img.jpg 404 (Not Found)

The error makes sense, the actual path to the image is something completely different (www.crashdiet.org/media/joomgallery/etc...)

All images show up fine in the backend.

Anyone have any ideas here? Would be truly grateful :) Thanks!

Best wishes

Peter


Title: Re: No photos in frontend (404 error) after enabling SEF
Post by: MrMusic on 24-01-2018 12:34:04
Hi,

is in the global configuration of Joomla sef enabled? Is a .htaccess exist in Joomla root?
Do you use a special sef extension or the function of Joomla?
Does it work if you turn off the advanced sef in the JoomGallery options?


Title: Re: No photos in frontend (404 error) after enabling SEF
Post by: loppis on 24-01-2018 12:36:32
Hi MrMusic and thanks for your reply :).

The solution was to turn off html suffix in Joomla SEF settings.

It took me days to figure out :)