maternal
Welcome, Guest. Please login or register.
Did you miss your activation email?

 
Advanced search

22750 Posts in 6706 Topics- by 17591 Members - Latest Member: permsk

28-05-2020 20:32:39
JOOM::GALLERY::FORUMRecent Posts
Pages: 1 ... 7 8 [9] 10
 81 
 on: 06-12-2018 15:11:23 
Started by Traveller19 - Last post by Traveller19
I have installed Joomgallery v 3.3.4 on a new Joomla 3.9.1 site (PHP 7.2).

I am using the default view in category view, but I unable to turn off the Comments and ratings. I think I have turned their options to "No" everywhere, but they still appear in the front end.

Any thoughts appreciated.

 82 
 on: 30-11-2018 19:15:34 
Started by jmarvin - Last post by jmarvin
JoomSEF even has a special extension (paid) for JoomGallery but it is still terrible for seo. NONE of the gallery images can be indexed for search as images.

index.php?view=image&format=raw&type=orig&id=7750&option=com_joomgallery
...vs...
/gallery/image.jpg

I had some success with "Image SEF URLs" but I would like to use the other benefits of a sef extension.

Has anyone discovered a way to use both?

Can something be done to the JoomSEF JoomGallery extension to make it work? A hack perhaps?

Can anything be done to JoomGallery to make them work?

I love JoomGallery and have used it for years on different projects but it sure would be nice if it supported some modern features, or worked just a little better on some things. Thanks everyone!

 83 
 on: 28-11-2018 22:33:23 
Started by jmarvin - Last post by jmarvin
It was suggested that all images have dimensions and alt for better seo.

I made these changes on node images in /media/mod_jgtreeview/js/dtree.js

<img src="' + ( (this.aIndent[n] == 1 && this.config.useLines) ? this.icon.line : this.icon.empty ) + '" alt="Tree Node" width="16" height="16" />

I hope this helps someone or gets added to the core.

 84 
 on: 28-11-2018 22:29:32 
Started by jmarvin - Last post by jmarvin
It was suggested that all images have dimensions and alt for better seo.

In /modules/mod_joomcat/helper.php around line 1000, I changed it to this...

$output   .= '    <img src="'.$this->_ambit->getImg($imgtype, $img, null, 0, true, $cropimgwidth, $cropimgheight, $cropimgpos).'" class="jg_photo'.$class.'" alt="'.$img->imgtitle.'"'.$extra.' width="'.$cropimgwidth.'" height="'.$cropimgheight.'" />';

I hope this helps someone or gets added to the core.

 85 
 on: 28-11-2018 22:24:19 
Started by jmarvin - Last post by jmarvin
I would like a better score on PageSpeed. It wants the images to be "losslessly" compressed.

1. One suggestion I found was to set the quality to 100% and that would be lossless, but that did not work.

2. Another suggestion was to make the files "interlaced." I added an entry to administrator/components/com_joomgallery/helpers/file.php but that didn't resolve the issue either.

imageinterlace($dst_img, true);

3. I found this suggestion as well...

Several tools are available that perform further, lossless compression on JPEG and PNG files, with no effect on image quality. For JPEG, we recommend jpegtran or jpegoptim (available on Linux only; run with the --strip-all option). For PNG, we recommend OptiPNG or PNGOUT.

Are these viable options?

How would they be integrated with JoomGallery?

Is there any way to "losslessly compress" the images using GD, GD2, or ImageMagick?


 86 
 on: 26-11-2018 14:12:15 
Started by Patjabix - Last post by MrMusic
Great, if it works again now. Smile
But I would only have been interested in how the problem arose.  Rolleyes

 87 
 on: 24-11-2018 10:28:47 
Started by Patjabix - Last post by Patjabix
Hello again

I managed to have my pictures and category shown, although I don't really know why I had the problem. Here is what I did:

I tested to move one of my last category in the root of categories instead of beeing in a sub-category.
And pictures were then visible.
I then recreated a sub-category and moved my "faulty" category in and the pictures were still visible.
I then moved all my catgeories in the newly created and removed the old "bad" category.
So now I have all pictures shown. But I don't know what was wrong with the category I needed to remove...

 88 
 on: 24-11-2018 09:57:06 
Started by Patjabix - Last post by Patjabix
Hello

I already check this (and did again just now)

Categories are published, visible and public.
Pictures are published, approved, visible and public.

As this happens for the hundredth catagory and following ones, I think there is a problem somewhere in configuration (or a strange bug ?)

What can I check ?

Thank you for you help

Patrice

 89 
 on: 23-11-2018 19:43:45 
Started by Patjabix - Last post by MrMusic
Hi,

I think the category does not contain images that are public visible.
Check this:
Category:
- published ?
- Access level ?
Images:
- published and approved ?
- access level ?
- not hidden ?
Check in the 'Image Manager' if the right category really contains images.

 90 
 on: 23-11-2018 14:23:35 
Started by Patjabix - Last post by Patjabix
Hello

Thank you for your answer :)

The code is like this:
{joomplucat:104 limit=20}

As a test, I simply changed value 104 for 99 and the pictures of category 99 were shown.
I tried your example instead :
{joomplucat:104 limit=12|columns=3}
but it doesn't work.

In "Maintenance Manager" no errors are shown.

What can I check ?

Thank you for you help

Patrice

Pages: 1 ... 7 8 [9] 10
HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 2912 access attempts in the last 7 days.