Welcome, Guest. Please login or register.
Did you miss your activation email?

 
Advanced search

22745 Posts in 6703 Topics- by 17593 Members - Latest Member: permsk

16-10-2019 02:58:38
JOOM::GALLERY::FORUMArchiveJoomGallery 1.5 MVCJoomGallery MVC ALPHASolved Topics: JoomGallery MVCSOLVED - problem of images not displaying & SEF problem...
Pages: [1] 2
Print
Author Topic: SOLVED - problem of images not displaying & SEF problem...  (Read 37259 times)
0 Members and 1 Guest are viewing this topic.
karban
Newbie
*
Offline Offline

Posts: 34



View Profile WWW
« on: 31-08-2010 05:56:09 »

Hi,
I have just found a solution to the problem of the large details page / slideshow images not displaying (....which I found was also fixed if you turn off Joomla SEF URLs.... but as that is not a very good solution I kept looking...and I found a suggestion for another issue in another post & thought I'd see if it also fixed my problems, which it did). 

I edited components/com_joomgallery/helpers/ambit.php by deleting the following lines (located around line number 191):
|| strpos($type, 'img')   !== false
|| strpos($type, 'orig')  !== false

This has fixed the image display & SEF problem!!!! Yippeeee - now images display perfectly & with Joomla SEF enabled. Cool

Hope this helps.
Regards, KB
Logged

http://www.business-in-site.com
Business-In-Site.com - the place for all your online business, marketing & start-up requirements. Features include: Web Directory, Affiliate Directory, Blog, Downloads directory, Videos, Tutorials & much more.
isand
Newbie
*
Offline Offline

Posts: 3


View Profile
« Reply #1 on: 19-09-2010 13:08:41 »

Thanks-a-lot! That has solved my problem, which was caused by the plugin myApiConnect. Now I can enable both SEF and myApiConnect.
Logged
karban
Newbie
*
Offline Offline

Posts: 34



View Profile WWW
« Reply #2 on: 20-09-2010 02:35:03 »

Glad it worked   Smilewinkgrin
Logged

http://www.business-in-site.com
Business-In-Site.com - the place for all your online business, marketing & start-up requirements. Features include: Web Directory, Affiliate Directory, Blog, Downloads directory, Videos, Tutorials & much more.
isand
Newbie
*
Offline Offline

Posts: 3


View Profile
« Reply #3 on: 21-09-2010 22:05:16 »

However, I can no longer download or view the original picture! All I get is a blank screen, unless I deactivate either SEF or myApiConnect.
Logged
karban
Newbie
*
Offline Offline

Posts: 34



View Profile WWW
« Reply #4 on: 21-09-2010 22:55:03 »

Hi isand,

Do you have the watermark feature enabled?
Another user has found that they had to also remove the watermark function too & then everything worked (I didn't have watermark function activated) - see this post for more details: http://www.forum.en.joomgallery.net/index.php?topic=3188.new;topicseen#new.

Let us know whether that works for you.......
Regards, Karen

PS: Whitescreen error usually means there is a php error somewhere - just wondering but are you sure that myAPI plugin is not part of the problem? (....it's just that I've read of some other users having problems with it, which is to be expected as it's only a beta release - one myAPI user said they then tried another product which worked flawlessly after no luck with myAPI..... Just a suggestion / thought  Smile
Logged

http://www.business-in-site.com
Business-In-Site.com - the place for all your online business, marketing & start-up requirements. Features include: Web Directory, Affiliate Directory, Blog, Downloads directory, Videos, Tutorials & much more.
isand
Newbie
*
Offline Offline

Posts: 3


View Profile
« Reply #5 on: 22-09-2010 17:35:49 »

All works now, after setting ``Add suffix to URLs =No''. Watermark is on, SEF is on.

Yes, the problem was being caused by myAPI, which is still BETA. But it's needed for facebook connection, so couldn't be disabled. Glad that it works now.

Thank you.

Logged
wdr
Newbie
*
Offline Offline

Posts: 1


View Profile
« Reply #6 on: 07-12-2010 16:22:30 »

Realy good job!
I used and solved my problem. But.... The hits doesnt working as well. Every hit dont move since this solution.
Anyone have a same problem?
Logged
Chraneco
Developer-Team
Hero Member
*****
Offline Offline

Posts: 3544


View Profile
« Reply #7 on: 17-12-2010 19:52:52 »

Hi,

the solution posted above shouldn't be used because of that and other reasons.

If you have problems with displaying images please revert your changes in the ambit and read this article.

Regards
Chraneco
Logged
tomsson
Newbie
*
Offline Offline

Posts: 10


View Profile
« Reply #8 on: 24-06-2011 01:15:07 »

Hi

I was update joomgallery to Version 1.5.7.2 and I have problem - no picture in detail wiev

see here: http://www.golebiarstwo.pl/galeria/brodawczaki/bagdeta-ostrawska-40.html

I was read article what you post and I turn off all of plugis except Joomla user and joomla authorizations plugin and this no fix my problem.

Can you help please?

Logged
Chraneco
Developer-Team
Hero Member
*****
Offline Offline

Posts: 3544


View Profile
« Reply #9 on: 24-06-2011 11:50:58 »

Hi,

may you please post the content of your .htaccess file?

Regards
Chraneco
Logged
tomsson
Newbie
*
Offline Offline

Posts: 10


View Profile
« Reply #10 on: 24-06-2011 12:06:06 »

Hi

Code:
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR]         ##optional - see notes##
RewriteCond %{REQUEST_URI} (/|.htm|.php|.html|/[^.]*)$  [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php
RewriteCond %{HTTP_HOST} ^golebiarstwo.pl(.*) [NC]
RewriteRule ^(.*)$ http://www.golebiarstwo.pl/$1 [R=301,L]
RewriteRule ^index.html$ http://www.golebiarstwo.pl [R=301,L,NC]



########## Begin - Rewrite rules to block out some common exploits
#                             
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*(.*) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (<|%3C).*script.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits


#ustalenie 'kolejki waznosci' wyswietlania domyslnego pliku
#index w zaleznosci od rozszerzenia
DirectoryIndex index.php index.html index.htm

#  zone h
deny from  .zone-h.org
deny from  .zone-h.com
deny from  213.219.122
deny from 62.150.154.23
 
# cyber-warrior.org
deny from  .cyber-warrior.org
deny from  .cyber-security.org
deny from   80.237.211.8
Deny from 201.244.38
Deny from 83.130.9.178
Deny from 212.138.113.25
Deny from 212.138.113.23
Deny from cache4-1.ruh.isu.net.sa
Deny from 212.138.113.24
Deny from cache3-2.ruh.isu.net.sa
Deny from cache11-4.ruh.isu.net.sa
Deny from 202.8.85.11
Deny from 222.124.11.98
Deny from 62.148.177.26
Deny from 85.88.1.99
Deny from 85.97.67.181
deny from 85.102.201.9   
deny from 85.103.232.27   
deny from 62.150.154.23   
deny from 217.16.29.51
Deny from 62.139.173.167
Deny from 212.138.113.23
Deny from 62.139.173.167
Deny from 82.129.189.97
Deny from 222.124.11.98
Deny from cache5-1.ruh.isu.net.sa
Deny from 82.145.205.194
Deny from pool-71-247-228-228.nycmny.east.verizon.net
Deny from 71.247.228.228
Deny from 202.65.236.122
Deny from 81.215.171.81
Deny from 85.101.138.179
Deny from 196.1.176.50
Deny from 136.red-83-45-120.dynamicip.rima-tde.net
Deny from 213.63.133.117
Deny from 63.94.224.93
Deny from h19.plesklogin.net
Deny from s2.server4user.de
Deny from seki.lunarpages.com
Deny from 82.165.151.41
Deny from fin01.rackglobal.com
Deny from s21.domenomania.pl
Deny from u15181562.onlinehome-server.com
Deny from dirgencom.drac.net
Deny from esc79.midphase.com 

Logged
Chraneco
Developer-Team
Hero Member
*****
Offline Offline

Posts: 3544


View Profile
« Reply #11 on: 24-06-2011 12:22:04 »

Hi,

this is not the original .htaccess file of Joomla. Because of that some things cannot work correctly.

Please replace the line

Code:
RewriteCond %{REQUEST_URI} (/|.htm|.php|.html|/[^.]*)$  [NC]

with the following one:

Code:
RewriteCond %{REQUEST_URI} (/[^.]*|\.(php|html?|feed|pdf|raw))$ [NC]

Regards
Chraneco
Logged
tomsson
Newbie
*
Offline Offline

Posts: 10


View Profile
« Reply #12 on: 24-06-2011 15:04:30 »

Thank You
Now works fine
Logged
LUCiD
Newbie
*
Offline Offline

Posts: 1


View Profile
« Reply #13 on: 15-07-2011 13:38:11 »

Hi,

the solution posted above shouldn't be used because of that and other reasons.

If you have problems with displaying images please revert your changes in the ambit and read this article.

Regards
Chraneco
hello,

i've had the same problem and after hours of searching the net about this problem, i have found that the component acesef (basic) generates this behavior. i don't know why, and in the past the function was very well. i guess something with the internal updates of the acesef component was wrong (altered code or something like that).
there was no problem with joomla plugins and only uninstalling/installing actual version of acesef corrected the problem.
Logged
Chraneco
Developer-Team
Hero Member
*****
Offline Offline

Posts: 3544


View Profile
« Reply #14 on: 15-07-2011 14:23:07 »

Hi,

thank you very much for the feed back!

Regards
Chraneco
Logged
Pages: [1] 2
Print
Jump to:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 8942 access attempts in the last 7 days.