imagematernal
Welcome, Guest. Please login or register.
Did you miss your activation email?

 
Advanced search

22747 Posts in 6705 Topics- by 17591 Members - Latest Member: permsk

25-02-2020 22:46:52
JOOM::GALLERY::FORUMJoomGallery 2.x ACL - ExtensionsModulesJoomGallery 2.1 - error when resizing thumbnails - images not showing at all
Pages: [1]
Print
Author Topic: JoomGallery 2.1 - error when resizing thumbnails - images not showing at all  (Read 5846 times)
0 Members and 1 Guest are viewing this topic.
Galeria Moderna
Newbie
*
Offline Offline

Posts: 7


View Profile
« on: 10-05-2013 05:19:10 »

Hi,

I read the instructions in the documentation. I changed the resize height and other things
and wanted to resize already uploaded images. Tried it with one and then the thumbnail didn't show
anymore. When I clik on the link, the only thing that is displayed, I get this error.

Warning: getimagesize(/home/xxxxxxxx/domains/xxxxxxxx.com/public_html/images/joomgallery/thumbnails/xxxxxxxx_2/xxxxxxxx_and_xxxxxxxx_xxxxxxxx_35/xxxxxxxx_and_xxxxxxxx_xxxxxxxx_xxxxxxxx_1638890911.jpg) [function.getimagesize]: failed to open stream: No such file or directory in /home/xxxxxxxx/domains/xxxxxxxx.com/public_html/components/com_joomgallery/views/category/view.html.php on line 690

What should I do to get the image back and how should I resize so this won't happen again?

I hope someone can help. Thanks in advance.

Greetings

Galeria
« Last Edit: 29-05-2013 12:39:11 by Galeria Moderna » Logged
Chraneco
Developer-Team
Hero Member
*****
Offline Offline

Posts: 3544


View Profile
« Reply #1 on: 11-05-2013 15:56:05 »

Hi,

what is the error message when recreating the thumbnails?

Regards
Chraneco
Logged
Galeria Moderna
Newbie
*
Offline Offline

Posts: 7


View Profile
« Reply #2 on: 28-05-2013 19:36:17 »

I dont understand...I got this when recreating the image/thumbnail

on the site I get this error I put in the previous  message. Do you know what is going wrong?
Logged
Chraneco
Developer-Team
Hero Member
*****
Offline Offline

Posts: 3544


View Profile
« Reply #3 on: 28-05-2013 21:47:29 »

Hi,

yes, there must have been an error message when using the recreate function in image manager.

Did you already do a check in maintenance manager?

Regards
Chraneco
Logged
Galeria Moderna
Newbie
*
Offline Offline

Posts: 7


View Profile
« Reply #4 on: 29-05-2013 12:37:52 »

Hi there,

Their might have been but I am not that familiar with JoomGallery and might have missed it.

I have done a check in the maintenance manager and now I see a lot if not all images are orphans, missing original and users and thumbnails.

The previous error I fixed by manually adding the file again. My question now is, is there a way of repairing all these files in one go? The error I get is that it cant find the file.
In the image manager part everything is approved and published but at the frond-end nothing is visible.
In the maintenance manager when I look for orphans I find all the files not showing. But cannot do a bulkfix. When I do this I get this error; The image '/home/******/domains/******.com/public_html/images/joomgallery/details/******_4/******_20120730_******.jpg' does not exist.

Any ideas?

ps. willing to give access to the site so you can see what is going wrong
Logged
Chraneco
Developer-Team
Hero Member
*****
Offline Offline

Posts: 3544


View Profile
« Reply #5 on: 29-05-2013 12:41:43 »

Hi,

yes, it would be good to have access to the maintenance manager.
You can send me login credentials via PM.

Regards
Chraneco
Logged
Galeria Moderna
Newbie
*
Offline Offline

Posts: 7


View Profile
« Reply #6 on: 29-05-2013 13:35:29 »

Ok, I just did. Thanks in advance!
Logged
Chraneco
Developer-Team
Hero Member
*****
Offline Offline

Posts: 3544


View Profile
« Reply #7 on: 29-05-2013 15:45:32 »

Hi,

thanks. Some folder permissions have been wrong (766 instead of 755). I changed that back to 755 and maintenance manager don't report any missing images or categories anymore (the orphaned images could be deleted).

Regards
Chraneco
Logged
Galeria Moderna
Newbie
*
Offline Offline

Posts: 7


View Profile
« Reply #8 on: 29-05-2013 18:24:40 »

Thanks a million.. I wouldn't have guessed this.

I dont understand though how this could happen. I surely dont remember change the permissions
on the folders. Is there a way for me to find out how this happend?

Greets

G
« Last Edit: 29-05-2013 18:39:36 by Galeria Moderna » Logged
Chraneco
Developer-Team
Hero Member
*****
Offline Offline

Posts: 3544


View Profile
« Reply #9 on: 29-05-2013 23:22:42 »

Hi,

sorry, I don't know. Since not all folders had the changed permissions I don't think that it was something automatic.
You should observe this in case it happens again.

Regards
Chraneco
Logged
Pages: [1]
Print
Jump to:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 2818 access attempts in the last 7 days.