maternal
Welcome, Guest. Please login or register.
Did you miss your activation email?

 
Advanced search

22434 Posts in 6637 Topics- by 10210 Members - Latest Member: Ganaao

19-11-2017 11:10:23
JOOM::GALLERY::FORUMJoomGallery 2.x ACLBackend / AdministrationSolved Topics: Backend / AdministrationStatic Defines error
Pages: [1]
Print
Author Topic: Static Defines error  (Read 6475 times)
0 Members and 1 Guest are viewing this topic.
rgtr
Newbie
*
Offline Offline

Posts: 6


View Profile
« on: 04-06-2013 13:08:32 »

Hi

installed as it seems to be what i want ...

but pages and pages of errors
how to fix ?

richard

---------------------------------

Strict Standards: Non-static method SimplePie_Misc::fix_protocol() should not be called statically, assuming $this from incompatible context in F:\JoomlaSites\lp_25\libraries\simplepie\simplepie.php on line 833

Strict Standards: Non-static method SimplePie_Misc::normalize_url() should not be called statically, assuming $this from incompatible context in F:\JoomlaSites\lp_25\libraries\simplepie\simplepie.php on line 9287

Strict Standards: Non-static method SimplePie_Misc::parse_url() should not be called statically, assuming $this from incompatible context in F:\JoomlaSites\lp_25\libraries\simplepie\simplepie.php on line 9288

Strict Standards: Non-static method SimplePie_Misc::parse_url() should not be called statically, assuming $this from incompatible context in F:\JoomlaSites\lp_25\libraries\simplepie\simplepie.php on line 1542

Strict Standards: Non-static method SimplePie_Misc::get_curl_version() should not be called statically, assuming $this from incompatible context in F:\JoomlaSites\lp_25\libraries\simplepie\simplepie.php on line 7675

Strict Standards: Non-static method SimplePie_Misc::get_curl_version() should not be called statically, assuming $this from incompatible context in F:\JoomlaSites\lp_25\libraries\simplepie\simplepie.php on line 7687

Strict Standards: Non-static method SimplePie_Misc::xml_encoding() should not be called statically, assuming $this from incompatible context in F:\JoomlaSites\lp_25\libraries\simplepie\simplepie.php on line 1721

Strict Standards: Non-static method SimplePie_Misc::xml_encoding() should not be called statically, assuming $this from incompatible context in F:\JoomlaSites\lp_25\libraries\simplepie\simplepie.php on line 1740

Strict Standards: Non-static method SimplePie_Misc::change_encoding() should not be called statically, assuming $this from incompatible context in F:\JoomlaSites\lp_25\libraries\simplepie\simplepie.php on line 1759

Strict Standards: Non-static method SimplePie_Misc::encoding() should not be called statically, assuming $this from incompatible context in F:\JoomlaSites\lp_25\libraries\simplepie\simplepie.php on line 9411

Strict Standards: Non-static method SimplePie_Misc::encoding() should not be called statically, assuming $this from incompatible context in F:\JoomlaSites\lp_25\libraries\simplepie\simplepie.php on line 9412

Strict Standards: Non-static method SimplePie_Parse_Date::get() should not be called statically, assuming $this from incompatible context in F:\JoomlaSites\lp_25\libraries\simplepie\simplepie.php on line 3609
Logged
Chraneco
Developer-Team
Hero Member
*****
Offline Offline

Posts: 3544


View Profile
« Reply #1 on: 04-06-2013 14:15:01 »

Hi,

these are messages from the SimplePie library that is not part of JoomGallery. The gallery just uses that library.

You can disable the output of these notice by changing the error reporting in global configuration of Joomla!.

Regards
Chraneco
Logged
rgtr
Newbie
*
Offline Offline

Posts: 6


View Profile
« Reply #2 on: 05-06-2013 18:09:13 »

hi

i am using Joomla! 2.5.11

i have tried to install your latest version and had the reported problem

the version os simplepi.php embedded in joomla 2.5.11 is 1.2

i donwloaded the latest version of simplepie and extracted the simplepie.php in libraries sub folder 1.3.1

i have simply copied it over the 1.2 version

install of joom::gallery is ok, hit the "go on" button ..

and

Fatal error: Class 'SimplePie_Misc' not found in F:\JoomlaSites\lp_25\libraries\simplepie\simplepie.php on line 59

i am sorry to say that i cannot use jjom::gallery till you tell me what to do ...

i am NOT a php guru, nor a joomla guru ... i just use it for five web sites i manage

i am sure many people will be getting the same and doing waht most do  - junk it and try the next one ..

the only add in i have is jcomments

apologies - but joom::gallery uses simplepie whish is PART of joomla 2.5.11 and it aint working ...

if you want me to set up a site and give you access please advise

r No
Logged
Chraneco
Developer-Team
Hero Member
*****
Offline Offline

Posts: 3544


View Profile
« Reply #3 on: 06-06-2013 02:35:38 »

Hi,

why didn't you do what I telled you?

It's not a good idea to override the SimplePie library with another version because that one is not compatible.

You have to undo your changes.

Please note: There weren't any errors before you have overridden the SimplePie library. These were only notices which can be disabled. JoomGallery is compatible with the SimplePie library that is shipped with Joomla!.

Regards
Chraneco
Logged
rgtr
Newbie
*
Offline Offline

Posts: 6


View Profile
« Reply #4 on: 06-06-2013 13:26:53 »

Hi

I have now taken a fresh install of joomla 2.5.11 and ONLY imported Joom::Gallery

I can still get the same errors as i first reported. my settings as shown in back end are:

Windows NT TDOCSERVER 5.2 build 3790 (Windows Server 2003 Standard Edition Service Pack 2) i586
Database Version    5.5.27
Database Collation    utf8_general_ci
PHP Version    5.4.7
Web Server    Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7
WebServer to PHP Interface    apache2handler
Joomla! Version    Joomla! 2.5.11 Stable [ Ember ] 26-April-2013 14:00 GMT
Joomla! Platform Version    Joomla Platform 11.4.0 Stable [ Brian Kernighan ] 03-Jan-2012 00:00 GMT
User Agent    Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.94 Safari/537.36

i thought may be that i had to upgrade simplepie. you say no - fine

i have now a lot more testing:

results are as follows
a) login and immediately click Joom:gallery off the components menu -> errors

b) in fact clicking Joom:gallery off the components menu ALWAYS -> errors
but the submenu is shown and using that is then error free

c) login and immediately click a subitem on the Joom:gallery off the components menu -> errors

d) BUT once the initialisation is complete, repeating c) all works fine, and

e) again once the initialisation is complete using the presented tab bar is fine.

for some 20 years i write software in ca-visual objects see wp.tdocplus.co.uk and tdoc.com so i am used to very strange bugs. this errors is ok ... will now test the user end

but PLEASE fix this initialisation ...

best regards

richard
Logged
Chraneco
Developer-Team
Hero Member
*****
Offline Offline

Posts: 3544


View Profile
« Reply #5 on: 06-06-2013 13:34:48 »

Hi,

you still did not do what I suggested: Please go to global configuration of Joomla! and set the error reporting to another level (e.g. 'Simple').

As I said before these are no errors, just notices.

Regards
Chraneco
Logged
rgtr
Newbie
*
Offline Offline

Posts: 6


View Profile
« Reply #6 on: 06-06-2013 16:38:38 »

Hi

I did a total rebuild of the stable site - viz did a phpmyadmin database delete

reinstalled and perfect

i conclude
a) akeeba kickstart does not truly drop the database - just some tables it knows about
b) this because i had tried one or two other solutions and rejected [uninstalled] them

now i am truly happy ...

richard
Logged
rgtr
Newbie
*
Offline Offline

Posts: 6


View Profile
« Reply #7 on: 07-06-2013 11:23:26 »

Hi

This morning back to pages of errors on initialisation ....

But as i said earlier, once this is over all is ok. so it is definitely an initialisation problem.

And so i dont think akeeba has anything to do with it.

judging by the number of other posts regarding simplepie some research seems necessary.

as a software writer myself i ALWAYS have maximum errors shown when i compile, and an error trapper that tells me what bit of what module calls what with line numbers. tedious i know

regards

richard
Logged
Chraneco
Developer-Team
Hero Member
*****
Offline Offline

Posts: 3544


View Profile
« Reply #8 on: 07-06-2013 11:34:57 »

Hi,

SimplePie is used only once during a session because its result are stored in session variables.

Please change the error reporting in global configuration of Joomla! and the notices will disappear.

Regards
Chraneco
Logged
rgtr
Newbie
*
Offline Offline

Posts: 6


View Profile
« Reply #9 on: 10-06-2013 12:44:48 »

Hi

Moved the site from my local [win 2003 server - see above fpr config] server which i use for testing and development to the live environment - config as below.

NO ERRORS at all - great so either its windows or php 5.4

thanks for a fantastic add on

richard

------------------------

PHP Built On    Linux web113.extendcp.co.uk 2.6.32-358.6.1.el6.cve20132094.x86_64 #1 SMP Tue May 14 15:27:28 CDT 2013 x86_64
Database Version    5.5.32-log
Database Collation    utf8_general_ci
PHP Version    5.3.23
Web Server    Apache/2
WebServer to PHP Interface    cgi-fcgi
Joomla! Version    Joomla! 2.5.11 Stable [ Ember ] 26-April-2013 14:00 GMT
Joomla! Platform Version    Joomla Platform 11.4.0 Stable [ Brian Kernighan ] 03-Jan-2012 00:00 GMT
User Agent    Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36
Logged
helderlopess
Newbie
*
Offline Offline

Posts: 1


View Profile
« Reply #10 on: 26-09-2014 15:12:03 »


Hi,

these are messages from the SimplePie library that is not part of JoomGallery. The gallery just uses that library.

You can disable the output of these notice by changing the error reporting in global configuration of Joomla!.

Regards
Chraneco

Thanks guy. You help me too much.
Logged
Pages: [1]
Print
Jump to:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 676 access attempts in the last 7 days.