Welcome, Guest. Please login or register.
Did you miss your activation email?

 
Advanced search

22745 Posts in 6703 Topics- by 17593 Members - Latest Member: permsk

16-10-2019 07:45:40
JOOM::GALLERY::FORUMJoomGallery 3.x JUXInstallation / Update"_assets" records and "_joomgallery" asset values missing after SP upgrade
Pages: [1]
Print
Author Topic: "_assets" records and "_joomgallery" asset values missing after SP upgrade  (Read 1557 times)
0 Members and 1 Guest are viewing this topic.
JEfromCanada
Newbie
*
Offline Offline

Posts: 1


View Profile
« on: 10-12-2014 02:09:11 »

Hello,

I have been recently trying to upgrade an ancient installation of Joomla 1.5.9 with Joomgallery 1.5.04 up to Joomla 3.3.6 with the latest Joomgallery version (3.2.0).  Here's what I've done so far:

I was successful in upgrading Joomla 1.5.9 to 1.5.26 using the published Joomla upgrade procedures.

I purchased the joomla extension SP Upgrade to do the migration from Joomla 1.5.26 to Joomla 3.3.6.

Before doing the migration, I thought I would make sure all my extensions were up to date.  I wanted to upgrade Joomgallery from 1.5.04 to 1.5.7.

From the Joomla 1.5.26 back end, I attempted the one-button upgrade to the three separate areas of Joomgallery.  Two of those updates were successful.

The third upgrade (modules, I believe) failed to update with the one-touch upgrade, and when I went looking for the zip file, it did not seem to be available any longer on the Joomgallery website.

After the "partial update" of Joomgallery, my Joomla website would no longer load (blank screen when I tried to access the main site URL).

The only solution that worked was to go back to a site backup (which I made just prior to the upgrade attempt).  This returned my site to operation, at level 1.5.26 for Joomla, and level 1.5.04 for Joomgallery.

I then ran the SP Upgrade process, which migrated my entire Joomla 1.5.26 site to version 3.3.6.  I migrated my joomgallery database tables from the Joomla 1.5.26 site to the Joomla 3.3.6 site using the SP Upgrade database migration feature.

After the migration, I noticed that SP Upgrade had not created the "prefix_joomgallery_catg" file due to differences in the table structure between the "old" and "new" versions of Joomgallery.  Luckily, I didn't have many categories, and was able to use the Joomgallery backend to recreate the categories manually.

Next, I noticed that the "new" version of the "catg" was pre-populated with a ROOT record, so that all the "category" references in the my "joomgallery" table were off by 1.  I wrote an SQL script to update the "joomgallery" table's category references to match the newly created categories.

At this point, I thought I was done, but when I tried to display the information from the Joomla gallery, none of the pictures would display.  I verified that the configuration was referencing the proper image folders, but still nothing.

I can only conclude that the "missing piece" is that the asset numbers in the new "prefix_joomgallery" are all set to zero (0), and there are no asset records in the "prefix_assets" table corresponding with the images.

So, with that background, here are my questions:

1)  Does someone have the full OFFICIAL version of joomgallery 1.5.7 (not a torrent download, as was suggested by a user in another thread), and if I were to apply this to the 1.5.04 version on Joomla 1.5.26, would that leave me with a file that can be easily migrated (by a Joomgallery update script) to version 3.2.0?  I have searched far and wide for an official version and don't trust any version downloaded from a torrent or "warez" site.

2)  Does someone have a script that can traverse my existing "prefix_joomgallery" table, and use that to create the missing "prefix_assets" records (and update the asset_id column of the "prefix_joomgallery" table).

3)  Barring that, does someone have technical specifications of what the various columns in the "prefix_asset" table mean (specifically the left and right fields - I can pretty much figure out the other fields), so that I can create my own update script to populate the "assets" table and update the fields in my "joomgallery" table?

Thank you very much for any help.

[EDIT]

I noticed that the "access" flag on the new "prefix_joomgallery" record was set to NULL.  I changed it to '1', and now the gallery of photos is being displayed.  I still have concerns about the missing asset numbers.
« Last Edit: 10-12-2014 02:19:04 by JEfromCanada » Logged
MrMusic
Administrator
Hero Member
*****
Offline Offline

Posts: 1084



View Profile
« Reply #1 on: 10-12-2014 14:39:04 »

Hi,

first: You find here a documentation about the migration from Joomla 1.5.
This manual also applies to a migration of 1.5 after 3.x. The Migratin script from 1.5 to 3.x you find here.
You should have a migration ONLY after this manual to make. Other tools are JoomGallery not migrate properly.

Secondly, you should see in the backend JoomGallery the update to 1.5.7.5. If it does not appear, it is likely a function disabled (allow_url_fopen) on your server.
Logged

From now on there is the support for the JoomGallery here: forum.en.joomgalleryfriends.net
Pages: [1]
Print
Jump to:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 9069 access attempts in the last 7 days.