Welcome, Guest. Please login or register.
Did you miss your activation email?

 
Advanced search

22745 Posts in 6703 Topics- by 17593 Members - Latest Member: permsk

22-10-2019 11:56:42
JOOM::GALLERY::FORUMJoomGallery 3.x JUXMigrationUser Problems after Migration from 2.1 to 3.3
Pages: [1]
Print
Author Topic: User Problems after Migration from 2.1 to 3.3  (Read 2692 times)
0 Members and 2 Guests are viewing this topic.
timleonard
Newbie
*
Offline Offline

Posts: 41


View Profile
« on: 26-12-2016 20:38:58 »

I am having a couple issues after migration from Joomla gallery 2.1 to 3.3. Using the script.


First, when using the frontend user panel "upload feature", it gives the following error but still uploads the photo to the proper user category.  Also there is no user id 63 as stated in reference  

        Warning
        JUser: :_load: Unable to load user with ID: 63
 
        Notice
        COM_MESSAGES_ERROR_INVALID_TO_USER

        Message
        Upload successfull!


 
Second, Logged in users can not create a new user category and can not delete a user uploaded photo.  Both give an error (HTTP 404 Not Found)

Third, can not install the JoomCategories.  It gives the following error:  

        Warning
        JInstaller: :Install: File does not exist xxxxxx\Joomla36\administrator\components\com_joomgallery\temp\update\JoomGallery-JoomCategories-904cbab\LICENSE.TXT

        Module %s: Could not copy files from the source.

        Error installing module

        MOD_JOOMCAT_DESC
        



All issues are the same with register access or super user access
I have checked the ACL permissions and the configuration manager settings but can't find the issue.

I appreciate any suggestions to help fix the issues

Thanks


 
« Last Edit: 28-12-2016 00:24:38 by timleonard » Logged
MrMusic
Administrator
Hero Member
*****
Offline Offline

Posts: 1084



View Profile
« Reply #1 on: 02-01-2017 12:56:30 »

Hi,

probably the Joomla! user with the id = 63 is no longer present in the new Joomla! installation. This user is still registered as the owner of a category or picture.
The migration script provides an option to check the users. To avoid the problem, you should run the migration again and activate the option 'Check owners'.
This should solve your first two problems.

To solve your third problem download the latest version of JoomCategories from here: https://github.com/JoomGallery/JoomCategories/releases/latest
After then you can install the zip file with the Joomla! extension manager.
Logged

From now on there is the support for the JoomGallery here: forum.en.joomgalleryfriends.net
timleonard
Newbie
*
Offline Offline

Posts: 41


View Profile
« Reply #2 on: 07-01-2017 04:52:53 »

Thank you for the response.

You were correct regarding user ID:63 not being present.  Turns out it was the approval setting in the backend.  It needed to be set it to the new admin ID:
The link to the JoomCategories also worked great...


However I am still having problems in that Logged in users cannot create user categories and cannot delete a user uploaded photo.  Both give an HTTP 404 Not Found error
(joomla36/gallery?task=category.save)  and  (joomla36/gallery?task=image.delete&id=4510)

Logged
MrMusic
Administrator
Hero Member
*****
Offline Offline

Posts: 1084



View Profile
« Reply #3 on: 10-01-2017 11:31:33 »

Thank you for the response.

You were correct regarding user ID:63 not being present.  Turns out it was the approval setting in the backend.  It needed to be set it to the new admin ID:
The link to the JoomCategories also worked great...
OK  Smile

However I am still having problems in that Logged in users cannot create user categories and cannot delete a user uploaded photo.  Both give an HTTP 404 Not Found error
(joomla36/gallery?task=category.save)  and  (joomla36/gallery?task=image.delete&id=4510)
I suspect the migration has not been performed properly. Please describe exactly how you proceeded the migration.
Logged

From now on there is the support for the JoomGallery here: forum.en.joomgalleryfriends.net
timleonard
Newbie
*
Offline Offline

Posts: 41


View Profile
« Reply #4 on: 11-01-2017 04:57:53 »

Used the migration manager 2.1 and used the following:

1. populated the paths to the old installation and images
2. set check owners to Yes
3. Copy Images to No. (It moved images to new installation)
4. set DB  prefix
5. click check box for external database
6. populated: host, user, password and set database name

7. Ran the "blue" check and everything showed green checks

After migration was complete, all images was moved and every show correctly.  The only problem is in the "user front end" and errors only when trying to delete image or create new category.  Note that it does upload without error and in to the correct user category.

Logged
MrMusic
Administrator
Hero Member
*****
Offline Offline

Posts: 1084



View Profile
« Reply #5 on: 11-01-2017 14:30:34 »

Ok, i would recommend the following:
1. Compare the old installation with the new Joomla installation, whether the 'user groups' with the same 'id' are present
2. Check/change the permission settings in the Control Panel of the JoomGallery (Options->Permissions), then 'Save & Close' - important!
3. Open a category where the upload doesn't work, check/change the settings in Permissions tab, then 'Save & Close' - important!
4. Are any errors displayed when you make a check in the Maintenance Maanager of the JoomGallery?
5. Does upload or delete work as a SuperUser in the frontend?

If you want you can send me an admin account to your page via pm, then i can make a look.
Logged

From now on there is the support for the JoomGallery here: forum.en.joomgalleryfriends.net
timleonard
Newbie
*
Offline Offline

Posts: 41


View Profile
« Reply #6 on: 12-01-2017 07:03:46 »

Ok, i would recommend the following:
Quote
1. Compare the old installation with the new Joomla installation, whether the 'user groups' with the same 'id' are present
There is one difference for the Guest Permission being ID:9... Old was ID:1 - 13 with no ID:10,11   The New is ID:1-12

Quote
2. Check/change the permission settings in the Control Panel of the JoomGallery (Options->Permissions), then 'Save & Close' - important!
I had already double check between old and new and made them match

Quote
3. Open a category where the upload doesn't work, check/change the settings in Permissions tab, then 'Save & Close' - important!
Did this.  Seems the same between old and new

Quote
4. Are any errors displayed when you make a check in the Maintenance Manager of the JoomGallery?
No...I ran this and it came up with nothing...

Quote
5. Does upload or delete work as a SuperUser in the frontend?
No it doesn't

Quote
If you want you can send me an admin account to your page via pm, then i can make a look.
sent via PM






Thanks for the help...Turns out it is a rewrite issue and not the script....
« Last Edit: 13-01-2017 01:08:08 by timleonard » Logged
Pages: [1]
Print
Jump to:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 8598 access attempts in the last 7 days.