Welcome, Guest. Please login or register.
Did you miss your activation email?

 
Advanced search

22750 Posts in 6706 Topics- by 17591 Members - Latest Member: permsk

28-05-2020 21:21:49
JOOM::GALLERY::FORUMArchiveJoomGallery 1.5 MVC - ExtensionsModulesError Message with Joomimage
Pages: [1]
Print
Author Topic: Error Message with Joomimage  (Read 6894 times)
0 Members and 1 Guest are viewing this topic.
Surprize
Newbie
*
Offline Offline

Posts: 2


View Profile
« on: 17-08-2008 23:39:29 »

doesnt work , working with jommla 1.5.4

get this error message if aktivated:
Code
Warning: Missing argument 1 for joommodule::getJoomId(), called in /mnt/web5/31/17/5776417/htdocs/germany/modules/mod_joomimg/mod_joomimg.php on line 120 and defined in /mnt/web5/31/17/5776417/htdocs/germany/components/com_joomgallery/classes/modules.class.php on line 93
 
Warning: getimagesize(/mnt/web5/31/17/5776417/htdocs/germany/components/com_joomgallery/img_thumbnails/bavarian_gigoolo_night_010508_97_20080817_1740435733.jpg) [function.getimagesize]: failed to open stream: No such file or directory in /mnt/web5/31/17/5776417/htdocs/germany/components/com_joomgallery/classes/modules.class.php on line 298
 
Warning: Division by zero in /mnt/web5/31/17/5776417/htdocs/germany/components/com_joomgallery/classes/modules.class.php on line 313
 
Warning: require(/mnt/web5/31/17/5776417/htdocs/germany/includes/administrator/components/com_joomgallery/joomgallery.config.php) [function.require]: failed to open stream: No such file or directory in /mnt/web5/31/17/5776417/htdocs/germany/components/com_joomgallery/includes/joom.javascript.php on line 211
 
Fatal error: require() [function.require]: Failed opening required '/mnt/web5/31/17/5776417/htdocs/germany/includes/administrator/components/com_joomgallery/joomgallery.config.php' (include_path='.:/opt/RZphp5/includes') in /mnt/web5/31/17/5776417/htdocs/germany/components/com_joomgallery/includes/joom.javascript.php on line 211

any ideas
Logged
aHa
Developer-Team
Hero Member
*****
Offline Offline

Posts: 990


View Profile WWW
« Reply #1 on: 20-08-2008 18:04:42 »

Hm,
it's curious.
Line 120 in modules.class.php
Code
function getJoomId($Itemid_modul="") {

What PHP version do you use on your web server?

Regards
Andreas
Logged
scandaloustruth
Newbie
*
Offline Offline

Posts: 2


View Profile
« Reply #2 on: 23-08-2008 07:41:13 »

I am also getting errors with this module (after uploading the first photo). Joomla 1.5.6, Rockettheme theme.

Warning: getimagesize(/home/nnidahoc/public_html/members/components/com_joomgallery/img_thumbnails/tame_1/puppyphotos034-1_20080822_1342243032.jpg) [function.getimagesize]: failed to open stream: No such file or directory in /home/nnidahoc/public_html/members/components/com_joomgallery/classes/modules.class.php on line 318

Warning: Division by zero in /home/nnidahoc/public_html/members/components/com_joomgallery/classes/modules.class.php on line 333
Logged
Pete
Newbie
*
Offline Offline

Posts: 2


View Profile
« Reply #3 on: 25-08-2008 18:02:39 »

Warning: getimagesize(/home/nnidahoc/public_html/members/components/com_joomgallery/img_thumbnails/tame_1/puppyphotos034-1_20080822_1342243032.jpg) [function.getimagesize]: failed to open stream: No such file or directory in /home/nnidahoc/public_html/members/components/com_joomgallery/classes/modules.class.php on line 318
Warning: Division by zero in /home/nnidahoc/public_html/members/components/com_joomgallery/classes/modules.class.php on line 333

I get the same error. I think the problem is that the path is wrong. The bold part is missing: ../components/com_joomgallery/img_thumbnails/user/64/...  (64 is the user-id).

Any help appreciated!
« Last Edit: 25-08-2008 20:46:58 by Pete » Logged
Pete
Newbie
*
Offline Offline

Posts: 2


View Profile
« Reply #4 on: 25-08-2008 21:32:33 »

I found the bugs  Cool
Here is how to fix the errors:

Edit the file components/classes/modules.class.php

Line 128 replace with red code:  (missing: p.owner,   )
        .", p.owner, p.imgtitle, p.imgtext, p.imgcounter, p.imgvotes\n"   
Line 318 replace with red code:      $thmsize = getimagesize($this->_config['thumbnailabspath'].$obj->owner.'/'.$obj->catpath.'/'.$obj->imgthumbname);   
Line 360 replace with red code:       $output .= "     <img src=\"".$this->_config['thumbnailpath'] .$obj->owner.'/'. $obj->catpath . '/' . $obj->imgthumbname."\" alt=\"".$obj->imgtitle."\" width=\"".$destWidth."\" height=\"".$destHeight."\" class=\"";


Edit file modules/mod_joomimg/mod_joomimg.php

Line 123 and 124 replace with this code:

$modConfig['thumbnailpath']          = $mosConfig_live_site.$jg_paththumbs."/user/";
$modConfig['thumbnailabspath']       = $mainframe->getCfg( 'absolute_path' ).$jg_paththumbs."/user/";


Good Luck :)
Logged
aHa
Developer-Team
Hero Member
*****
Offline Offline

Posts: 990


View Profile WWW
« Reply #5 on: 26-08-2008 19:21:32 »

Hi,
@Pete: thank you for the modifications.

We have decided to integrate the usergalleries in the existing structure of the gallery.
Please see here for more details.

Installing the new version of the BETA should solve the problems.

Regards
Andreas
« Last Edit: 26-08-2008 19:32:35 by aHa » Logged
Pages: [1]
Print
Jump to:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 2925 access attempts in the last 7 days.

maternal